Technické požadavky na provoz Joomla

Požadavky pro Joomla 2.5.x

Software  Doporučená   Minimální   Více informací
PHP  5.4 +  5.2.4 +  www.php.net
MySQL  5.0.4 +  5.0.4 +  www.mysql.com
Apache*  2.x +  2.x +  www.apache.org
MS IIS  7 7 www.iis.net


* s mod_mysql, mod_xml, a mod_zlib

Požadavky pro Joomla 1.5.x

Software  Doporučená   Minimální   Více informací
PHP  5.2 nebo 5.3 4.3.10 www.php.net
MySQL 4.1.x +  3.23 www.mysql.com
Apache*  2.x +  1.3 www.apache.org
MS IIS 7 6 www.iis.net


* s mod_mysql, mod_xml, a mod_zlib

Nepoužívejte PHP 4.3.9, 4.4.2 nebo 5.0.4. Tato vydání obsahují známé chyby, které ovlivňují instalaci. Zend Optimizer 2.5.10 pro PHP 4.4.x také obsahuje závažné chyby a měli byste požádat webhosting o přechod na novější verzi. Joomla! verze 1.5.15 + je kompatibilní s PHP 5.3.

Joomla není kompatibilní s MySQL 6.x.